summaryrefslogtreecommitdiffstats
path: root/noatun/modules/noatunui/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'noatun/modules/noatunui/Makefile.am')
-rw-r--r--noatun/modules/noatunui/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/noatun/modules/noatunui/Makefile.am b/noatun/modules/noatunui/Makefile.am
new file mode 100644
index 00000000..443afd6c
--- /dev/null
+++ b/noatun/modules/noatunui/Makefile.am
@@ -0,0 +1,16 @@
+INCLUDES= -I$(top_srcdir)/noatun/library $(all_includes)
+kde_module_LTLIBRARIES = noatun_ui.la
+
+noatun_ui_la_SOURCES = noatunui.cpp userinterface.cpp
+
+noatun_ui_la_LDFLAGS = $(all_libraries) -module -avoid-version -no-undefined
+noatun_ui_la_LIBADD = $(LIB_KFILE) $(top_builddir)/noatun/library/libnoatun.la \
+ $(top_builddir)/noatun/library/libnoatuncontrols.la \
+ -lqtmcop -lkmedia2_idl -lsoundserver_idl
+
+noatun_ui_la_METASOURCES = AUTO
+
+noinst_HEADERS = userinterface.h
+
+noatun_modules_ui_DATA = noatunui.plugin
+noatun_modules_uidir = $(kde_datadir)/noatun