summaryrefslogtreecommitdiffstats
path: root/noatun/modules/systray/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'noatun/modules/systray/Makefile.am')
-rw-r--r--noatun/modules/systray/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/noatun/modules/systray/Makefile.am b/noatun/modules/systray/Makefile.am
new file mode 100644
index 00000000..1dcfdd25
--- /dev/null
+++ b/noatun/modules/systray/Makefile.am
@@ -0,0 +1,16 @@
+INCLUDES= -I$(top_srcdir)/noatun/library $(all_includes)
+kde_module_LTLIBRARIES = noatun_systray.la
+
+noatun_systray_la_SOURCES = systray.cpp noatunui.cpp kitsystemtray.cpp cmodule.cpp \
+ yhconfig.kcfgc yhconfigwidget.ui
+
+
+noatun_systray_la_LDFLAGS = $(all_libraries) -module -avoid-version -no-undefined
+noatun_systray_la_LIBADD = $(LIB_KFILE) $(top_builddir)/noatun/library/libnoatun.la
+
+noatun_systray_la_METASOURCES = AUTO
+
+noinst_HEADERS = systray.h kitsystemtray.h cmodule.h
+
+noatun_modules_systray_DATA = systray.plugin systrayui.rc yhconfig.kcfg
+noatun_modules_systraydir = $(kde_datadir)/noatun