summaryrefslogtreecommitdiffstats
path: root/tdeioslave/audiocd/plugins/vorbis/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tdeioslave/audiocd/plugins/vorbis/CMakeLists.txt')
-rw-r--r--tdeioslave/audiocd/plugins/vorbis/CMakeLists.txt44
1 files changed, 44 insertions, 0 deletions
diff --git a/tdeioslave/audiocd/plugins/vorbis/CMakeLists.txt b/tdeioslave/audiocd/plugins/vorbis/CMakeLists.txt
new file mode 100644
index 00000000..35032740
--- /dev/null
+++ b/tdeioslave/audiocd/plugins/vorbis/CMakeLists.txt
@@ -0,0 +1,44 @@
+#################################################
+#
+# (C) 2017 Slávek Banko
+# slavek (DOT) banko (AT) axis.cz
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}/..
+ ${CMAKE_SOURCE_DIR}/libkcddb
+ ${TQT_INCLUDE_DIRS}
+ ${TDE_INCLUDE_DIR}
+ ${TAGLIB_INCLUDE_DIR}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${TAGLIB_LIBRARY_DIRS}
+)
+
+
+##### libaudiocd_encoder_vorbis (module) ########
+
+tde_add_kpart( libaudiocd_encoder_vorbis AUTOMOC
+ SOURCES
+ audiocd_vorbis_encoder.kcfgc
+ encodervorbis.cpp
+ encodervorbisconfig.ui
+ LINK
+ tdeio-shared audiocdplugins-shared
+ ${OGG_LIBRARIES} ${VORBIS_LIBRARIES} ${VORBISFILE_LIBRARIES} ${VORBISENC_LIBRARIES}
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)
+
+
+##### other data ################################
+
+install( FILES audiocd_vorbis_encoder.kcfg DESTINATION ${KCFG_INSTALL_DIR} )