summaryrefslogtreecommitdiffstats
path: root/wifi/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-07-08 22:39:20 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-07-08 22:39:20 +0200
commitd36d9267539f12fdaa5a0dd18f6285e4a636e1ac (patch)
tree65966d4e78c0529e0e56f8586a7d9c2ae530d336 /wifi/CMakeLists.txt
parent54888da0ae983555ec963c52007c50d49b3c66af (diff)
downloadtdenetwork-d36d9267539f12fdaa5a0dd18f6285e4a636e1ac.tar.gz
tdenetwork-d36d9267539f12fdaa5a0dd18f6285e4a636e1ac.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'wifi/CMakeLists.txt')
-rw-r--r--wifi/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/wifi/CMakeLists.txt b/wifi/CMakeLists.txt
index 1e1ae90b..2ce4c51f 100644
--- a/wifi/CMakeLists.txt
+++ b/wifi/CMakeLists.txt
@@ -36,8 +36,13 @@ endif( )
##### other data ################################
tde_install_icons( )
+
install( FILES kwifimanagerui.rc DESTINATION ${DATA_INSTALL_DIR}/kwifimanager )
-install( FILES kwifimanager.desktop DESTINATION ${XDG_APPS_INSTALL_DIR} )
+
+tde_create_translated_desktop(
+ SOURCE kwifimanager.desktop
+ PO_DIR wifi-desktops
+)
##### kwifimanager (executable) #################