summaryrefslogtreecommitdiffstats
path: root/knewsticker/knewstickerstub/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'knewsticker/knewstickerstub/CMakeLists.txt')
-rw-r--r--knewsticker/knewstickerstub/CMakeLists.txt38
1 files changed, 38 insertions, 0 deletions
diff --git a/knewsticker/knewstickerstub/CMakeLists.txt b/knewsticker/knewstickerstub/CMakeLists.txt
new file mode 100644
index 00000000..970db280
--- /dev/null
+++ b/knewsticker/knewstickerstub/CMakeLists.txt
@@ -0,0 +1,38 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}/../common
+ ${CMAKE_BINARY_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### other data ################################
+
+install( FILES
+ knewstickerstub.desktop
+ DESTINATION ${APPS_INSTALL_DIR}/.hidden )
+
+
+##### knewstickerstub (executable) ##############
+
+tde_add_executable( knewstickerstub AUTOMOC
+ SOURCES knewstickerstub.cpp
+ LINK knewstickercommon-static kio-shared
+ DESTINATION ${BIN_INSTALL_DIR}
+)