summaryrefslogtreecommitdiffstats
path: root/knewsticker/kntsrcfilepropsdlg/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'knewsticker/kntsrcfilepropsdlg/CMakeLists.txt')
-rw-r--r--knewsticker/kntsrcfilepropsdlg/CMakeLists.txt42
1 files changed, 42 insertions, 0 deletions
diff --git a/knewsticker/kntsrcfilepropsdlg/CMakeLists.txt b/knewsticker/kntsrcfilepropsdlg/CMakeLists.txt
new file mode 100644
index 00000000..f6d02b06
--- /dev/null
+++ b/knewsticker/kntsrcfilepropsdlg/CMakeLists.txt
@@ -0,0 +1,42 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+tde_import( librss )
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}/../common
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_SOURCE_DIR}/librss
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### other data ################################
+
+install( FILES
+ kntsrcfilepropsdlg.desktop
+ DESTINATION ${SERVICES_INSTALL_DIR} )
+
+
+##### kntsrcfilepropsdlg (module) ###############
+
+tde_add_kpart( kntsrcfilepropsdlg AUTOMOC
+ SOURCES
+ kntsrcfilepropsdlg.cpp kntsrcfilepropsdlgwidget.ui
+ LINK knewstickercommon-static rss-shared
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)