summaryrefslogtreecommitdiffstats
path: root/karm/test/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commit460c52653ab0dcca6f19a4f492ed2c5e4e963ab0 (patch)
tree67208f7c145782a7e90b123b982ca78d88cc2c87 /karm/test/Makefile.am
downloadtdepim-460c52653ab0dcca6f19a4f492ed2c5e4e963ab0.tar.gz
tdepim-460c52653ab0dcca6f19a4f492ed2c5e4e963ab0.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdepim@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'karm/test/Makefile.am')
-rw-r--r--karm/test/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/karm/test/Makefile.am b/karm/test/Makefile.am
new file mode 100644
index 00000000..7205a599
--- /dev/null
+++ b/karm/test/Makefile.am
@@ -0,0 +1,18 @@
+METASOURCES = AUTO
+
+check_PROGRAMS = runscripts locking
+
+runscripts_SOURCES = script.cpp runscripts.cpp
+runscripts_LDFLAGS = $(all_libraries) $(KDE_RPATH)
+runscripts_LDADD = $(LIB_QT) $(LIB_KDECORE)
+
+locking_SOURCES = locking.cpp lockerthread.cpp
+locking_LDFLAGS = $(all_libraries) $(KDE_RPATH)
+locking_LDADD = $(LIB_QT) $(top_builddir)/libkcal/libkcal.la
+
+KDE_CXXFLAGS = $(USE_EXCEPTIONS)
+
+INCLUDES = -I$(srcdir) -I$(top_srcdir) -I$(top_srcdir)/libkcal $(all_includes)
+
+#TESTS = runscripts locking
+TESTS = locking