summaryrefslogtreecommitdiffstats
path: root/kmail/Makefile.am
diff options
context:
space:
mode:
authortpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2010-09-01 00:37:02 +0000
committertpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2010-09-01 00:37:02 +0000
commitcc29364f06178f8f6b457384f2ec37a042bd9d43 (patch)
tree7c77a3184c698bbf9d98cef09fb1ba8124daceba /kmail/Makefile.am
parent4f6c584bacc8c3c694228f36ada3de77a76614a6 (diff)
downloadtdepim-cc29364f06178f8f6b457384f2ec37a042bd9d43.tar.gz
tdepim-cc29364f06178f8f6b457384f2ec37a042bd9d43.zip
* Massive set of changes to bring in all fixes and enhancements from the Enterprise PIM branch
* Ensured that the Trinity changes were applied on top of those enhancements, and any redundancy removed * Added journal read support to the CalDAV resource * Fixed CalDAV resource to use events URL for tasks and journals when separate URL checkbox unchecked git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdepim@1170461 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kmail/Makefile.am')
-rw-r--r--kmail/Makefile.am23
1 files changed, 16 insertions, 7 deletions
diff --git a/kmail/Makefile.am b/kmail/Makefile.am
index 56b89dbc..62939092 100644
--- a/kmail/Makefile.am
+++ b/kmail/Makefile.am
@@ -1,5 +1,5 @@
#KDE_OPTIONS = nofinal
-KDE_CXXFLAGS = $(USE_RTTI)
+KDE_CXXFLAGS = $(USE_RTTI) -fexceptions
SUBDIRS = interfaces . about pics profiles avscripts tests
@@ -91,6 +91,7 @@ libkmailprivate_la_SOURCES = kmmessage.cpp kmmainwin.cpp configuredialog.cpp \
headerstrategy.cpp headerstyle.cpp khtmlparthtmlwriter.cpp \
filehtmlwriter.cpp teehtmlwriter.cpp \
mailcomposerIface.skel objecttreeparser.cpp \
+ objecttreeparser_p.cpp \
attachmentcollector.cpp \
bodypartformatter.cpp bodypartformatterfactory.cpp \
partNode.cpp \
@@ -150,7 +151,15 @@ libkmailprivate_la_SOURCES = kmmessage.cpp kmmainwin.cpp configuredialog.cpp \
snippetsettingsbase.ui \
scalix.cpp \
messageactions.cpp \
- korghelper.cpp
+ korghelper.cpp \
+ foldersetselector.cpp \
+ stringutil.cpp \
+ treebase.cpp \
+ backupjob.cpp \
+ importjob.cpp \
+ folderutil.cpp \
+ archivefolderdialog.cpp \
+ importarchivedialog.cpp
libkmailprivate_la_COMPILE_FIRST = globalsettings_base.h customtemplates_base.h templatesconfiguration_base.h
@@ -209,7 +218,7 @@ update_SCRIPTS = upgrade-transport.pl kmail-pgpidentity.pl \
kmail-3.3b1-misc.pl \
kmail-3.4-misc.pl \
kmail-3.4.1-update-status-filters.pl \
- kmail-3.5-filter-icons.pl \
+ kmail-3.5-filter-icons.pl \
kmail-3.5-trigger-flag-migration.pl
confdir = $(kde_confdir)
@@ -226,10 +235,10 @@ kde_services_DATA = kmail_config_misc.desktop kmail_config_appearance.desktop \
kmail_config_security.desktop
messages: rc.cpp
- rm -f tips.txt
- $(PREPARETIPS) > tips.txt
- $(XGETTEXT) -ktranslate *.cpp *.txt *.h -o $(podir)/kmail.pot
- rm -f tips.txt
+ rm -f tips.cpp
+ $(PREPARETIPS) > tips.cpp
+ $(XGETTEXT) -ktranslate *.cpp *.h -o $(podir)/kmail.pot
+ rm -f tips.cpp
kde_kcfg_DATA = kmail.kcfg replyphrases.kcfg custommimeheader.kcfg \
templatesconfiguration_kfg.kcfg customtemplates_kfg.kcfg