summaryrefslogtreecommitdiffstats
path: root/kmobile/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-07-12 16:15:10 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-07-12 16:15:10 +0200
commit0d3043b6308af148da06ac14c53defc4b1e7e138 (patch)
tree2e9364cb143e70ee062e443275b852b8e2061888 /kmobile/CMakeLists.txt
parent7c7363c3ca7fb9633d93cefde3cd54b144eee633 (diff)
downloadtdepim-0d3043b6308af148da06ac14c53defc4b1e7e138.tar.gz
tdepim-0d3043b6308af148da06ac14c53defc4b1e7e138.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'kmobile/CMakeLists.txt')
-rw-r--r--kmobile/CMakeLists.txt14
1 files changed, 12 insertions, 2 deletions
diff --git a/kmobile/CMakeLists.txt b/kmobile/CMakeLists.txt
index 1c5cf0c0..43cff0a6 100644
--- a/kmobile/CMakeLists.txt
+++ b/kmobile/CMakeLists.txt
@@ -31,8 +31,18 @@ link_directories(
##### other data ################################
tde_install_icons( kmobile )
-install( FILES kmobile.desktop DESTINATION ${XDG_APPS_INSTALL_DIR} )
-install( FILES libkmobile.desktop DESTINATION ${SERVICETYPES_INSTALL_DIR} )
+
+tde_create_translated_desktop(
+ SOURCE kmobile.desktop
+ PO_DIR kmobile-desktops
+)
+
+tde_create_translated_desktop(
+ SOURCE libkmobile.desktop
+ DESTINATION ${SERVICETYPES_INSTALL_DIR}
+ PO_DIR kmobile-desktops
+)
+
install( FILES kmobileui.rc DESTINATION ${DATA_INSTALL_DIR}/kmobile )