summaryrefslogtreecommitdiffstats
path: root/kmobile/tdeioslave/Makefile.am
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-27 01:05:15 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-27 01:05:15 -0600
commit64df902cf71a8ee258fb85f6be26248f399aa01f (patch)
treedba58f705042c22cea26b678d5b0e4e9a34bf202 /kmobile/tdeioslave/Makefile.am
parentde53c98cab07e9c4b0f5e25dab82830fb6fc67ec (diff)
downloadtdepim-64df902cf71a8ee258fb85f6be26248f399aa01f.tar.gz
tdepim-64df902cf71a8ee258fb85f6be26248f399aa01f.zip
Rename a number of libraries and executables to avoid conflicts with KDE4
Diffstat (limited to 'kmobile/tdeioslave/Makefile.am')
-rw-r--r--kmobile/tdeioslave/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/kmobile/tdeioslave/Makefile.am b/kmobile/tdeioslave/Makefile.am
new file mode 100644
index 00000000..df5288ec
--- /dev/null
+++ b/kmobile/tdeioslave/Makefile.am
@@ -0,0 +1,18 @@
+SUBDIRS = mimetypes
+
+INCLUDES = -I$(top_srcdir)/kmobile -I$(top_srcdir) $(all_includes)
+
+kde_module_LTLIBRARIES = kio_mobile.la
+
+kio_mobile_la_SOURCES = kio_mobile.cpp
+kio_mobile_la_LIBADD = $(LIB_KIO) ../libkmobileclient.la
+kio_mobile_la_LDFLAGS = $(all_libraries) $(KDE_RPATH) -module $(KDE_PLUGIN)
+
+kde_services_DATA = mobile.protocol cellphone.protocol \
+ organizer.protocol pda.protocol
+# do not install the camera protocol now - we already have a
+# camera tdeioslave !!
+# phonecamera.protocol
+
+messages:
+ $(XGETTEXT) *.cpp -o $(podir)/tdeio_mobile.pot