summaryrefslogtreecommitdiffstats
path: root/kode/CMakeLists.txt
diff options
context:
space:
mode:
authorsamelian <samelian@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2011-03-21 00:29:04 +0000
committersamelian <samelian@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2011-03-21 00:29:04 +0000
commitf5b07a4a12d57d28dee8662d296dd400d26ba7fe (patch)
tree24b4c61a0576f1c5d3571cc8d6c81262e6171227 /kode/CMakeLists.txt
parent6bab61d816e8321b2d66a7183af04269a832ea81 (diff)
downloadtdepim-f5b07a4a12d57d28dee8662d296dd400d26ba7fe.tar.gz
tdepim-f5b07a4a12d57d28dee8662d296dd400d26ba7fe.zip
[kdepim] initial cmake support for: knotes, kode, korganizer, kresources, plugins, wizards
git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdepim@1225440 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kode/CMakeLists.txt')
-rw-r--r--kode/CMakeLists.txt43
1 files changed, 43 insertions, 0 deletions
diff --git a/kode/CMakeLists.txt b/kode/CMakeLists.txt
new file mode 100644
index 00000000..d02a1b30
--- /dev/null
+++ b/kode/CMakeLists.txt
@@ -0,0 +1,43 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+add_subdirectory( kxml_compiler )
+
+include_directories(
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### kode (executable) #########################
+
+tde_add_executable( kode
+ SOURCES kodemain.cpp
+ LINK kode-shared kabc-shared
+ DESTINATION ${BIN_INSTALL_DIR}
+)
+
+
+##### kode (shared) #############################
+
+tde_add_library( kode SHARED
+ SOURCES
+ code.cpp enum.cpp style.cpp printer.cpp license.cpp file.cpp class.cpp
+ function.cpp variable.cpp membervariable.cpp typedef.cpp statemachine.cpp
+ automakefile.cpp
+ VERSION 1.0.0
+ LINK kdecore-shared
+ DESTINATION ${LIB_INSTALL_DIR}
+)