summaryrefslogtreecommitdiffstats
path: root/kresources/kolab/shared/CMakeLists.txt
diff options
context:
space:
mode:
authorsamelian <samelian@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2011-03-21 00:29:04 +0000
committersamelian <samelian@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2011-03-21 00:29:04 +0000
commitf5b07a4a12d57d28dee8662d296dd400d26ba7fe (patch)
tree24b4c61a0576f1c5d3571cc8d6c81262e6171227 /kresources/kolab/shared/CMakeLists.txt
parent6bab61d816e8321b2d66a7183af04269a832ea81 (diff)
downloadtdepim-f5b07a4a12d57d28dee8662d296dd400d26ba7fe.tar.gz
tdepim-f5b07a4a12d57d28dee8662d296dd400d26ba7fe.zip
[kdepim] initial cmake support for: knotes, kode, korganizer, kresources, plugins, wizards
git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdepim@1225440 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'kresources/kolab/shared/CMakeLists.txt')
-rw-r--r--kresources/kolab/shared/CMakeLists.txt29
1 files changed, 29 insertions, 0 deletions
diff --git a/kresources/kolab/shared/CMakeLists.txt b/kresources/kolab/shared/CMakeLists.txt
new file mode 100644
index 00000000..e06e1bce
--- /dev/null
+++ b/kresources/kolab/shared/CMakeLists.txt
@@ -0,0 +1,29 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_SOURCE_DIR}
+ ${CMAKE_SOURCE_DIR}/kresources/lib
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+
+##### resourcekolabshared (static) ##############
+
+set( KDE3_DCOPIDL_EXECUTABLE ${KDE3_DCOPIDLNG_EXECUTABLE} )
+
+tde_add_library( resourcekolabshared STATIC_PIC AUTOMOC
+ SOURCES
+ resourcekolabbase.cpp kmailconnection.cpp kolabbase.cpp subresource.cpp
+ kmailconnection.skel ${CMAKE_SOURCE_DIR}/kmail/kmailicalIface.stub
+)