summaryrefslogtreecommitdiffstats
path: root/libkcal/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2019-03-27 23:27:22 +0900
committerSlávek Banko <slavek.banko@axis.cz>2019-04-01 18:36:29 +0200
commit9d6e89d4db97c351466d41b958605091075563b5 (patch)
tree801dd8129e47d87632adcbe4510b5467dc56d9cf /libkcal/tests/CMakeLists.txt
parent77ffd0e710a5ea62b3c36e37cf82fd66df5b6512 (diff)
downloadtdepim-9d6e89d4db97c351466d41b958605091075563b5.tar.gz
tdepim-9d6e89d4db97c351466d41b958605091075563b5.zip
Fixed bug in libkcal related to timezones in DT field.
Fixed execution of libkcal tests. This resolves bug 2719. Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it> (cherry picked from commit 48af72cbe8a4f0cc22de3e2ceda5db47ca922759)
Diffstat (limited to 'libkcal/tests/CMakeLists.txt')
-rw-r--r--libkcal/tests/CMakeLists.txt8
1 files changed, 5 insertions, 3 deletions
diff --git a/libkcal/tests/CMakeLists.txt b/libkcal/tests/CMakeLists.txt
index 386982c4..3f3603d4 100644
--- a/libkcal/tests/CMakeLists.txt
+++ b/libkcal/tests/CMakeLists.txt
@@ -59,13 +59,15 @@ add_custom_command(
WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
)
+# Compat tests are broken and have been in a disabled state since before TDE exited
set ( _test1 testrecurrence "next" ${CMAKE_CURRENT_SOURCE_DIR}/data/RecurrenceRule/*.ics )
set ( _test2 testrecurprevious "prev" ${CMAKE_CURRENT_SOURCE_DIR}/data/RecurrenceRule/*.ics )
set ( _test3 testrecurson "recurson" ${CMAKE_CURRENT_SOURCE_DIR}/data/RecurrenceRule/*.ics )
-set ( _test4 readandwrite "ical" ${CMAKE_CURRENT_SOURCE_DIR}/data/Compat/*.ics )
+#set ( _test4 readandwrite "ical" ${CMAKE_CURRENT_SOURCE_DIR}/data/Compat/*.ics )
set ( _test5 testvcalexport "vcal" ${CMAKE_CURRENT_SOURCE_DIR}/data/vCalendar/*.ics )
set ( _test6 readandwrite "ical" ${CMAKE_CURRENT_SOURCE_DIR}/data/vCalendar/*.vcs )
-set ( _all_tests _test1 _test2 _test3 _test4 _test5 _test6 )
+#set ( _all_tests _test1 _test2 _test3 _test4 _test5 _test6 )
+set ( _all_tests _test1 _test2 _test3 _test5 _test6 )
foreach( _test_name ${_all_tests} )
list( GET ${_test_name} 0 _test_executable )
@@ -74,7 +76,7 @@ foreach( _test_name ${_all_tests} )
file( GLOB_RECURSE _test_files RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} ${_test_search_filter} )
foreach( _test_file ${_test_files} )
add_test(
- ${_test_executable}__${_test_file}__
+ ${_test_executable}__${_test_id}__${_test_file}__
${CMAKE_CURRENT_SOURCE_DIR}/runtestcase.pl ${_test_executable} ${_test_id} ${CMAKE_CURRENT_BINARY_DIR}/${_test_file}
)
endforeach( )