summaryrefslogtreecommitdiffstats
path: root/tdeioslaves/sieve/Makefile.am
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-27 01:05:15 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-27 01:05:15 -0600
commit64df902cf71a8ee258fb85f6be26248f399aa01f (patch)
treedba58f705042c22cea26b678d5b0e4e9a34bf202 /tdeioslaves/sieve/Makefile.am
parentde53c98cab07e9c4b0f5e25dab82830fb6fc67ec (diff)
downloadtdepim-64df902cf71a8ee258fb85f6be26248f399aa01f.tar.gz
tdepim-64df902cf71a8ee258fb85f6be26248f399aa01f.zip
Rename a number of libraries and executables to avoid conflicts with KDE4
Diffstat (limited to 'tdeioslaves/sieve/Makefile.am')
-rw-r--r--tdeioslaves/sieve/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/tdeioslaves/sieve/Makefile.am b/tdeioslaves/sieve/Makefile.am
new file mode 100644
index 00000000..f4d0639c
--- /dev/null
+++ b/tdeioslaves/sieve/Makefile.am
@@ -0,0 +1,15 @@
+INCLUDES= -I$(srcdir)/../.. -I$(srcdir)/.. $(all_includes)
+
+kde_module_LTLIBRARIES = kio_sieve.la
+
+kio_sieve_la_SOURCES = sieve.cpp
+kio_sieve_la_LIBADD = $(LIB_KIO) $(SASL2_LIBS) $(LIB_QT) $(LIB_TDECORE)
+kio_sieve_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN)
+
+noinst_HEADERS = sieve.h
+
+kdelnk_DATA = sieve.protocol
+kdelnkdir = $(kde_servicesdir)
+
+messages:
+ $(XGETTEXT) *.cpp -o $(podir)/tdeio_sieve.pot