summaryrefslogtreecommitdiffstats
path: root/tderesources/Makefile.am
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-26 13:17:50 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-26 13:17:50 -0600
commitb363d2579af0a11b77e698aed2e1021c2233b644 (patch)
treef4a47b87354b7a6a3b266c8121bd8ddaeb7accaa /tderesources/Makefile.am
parent61bddfe3a7226b18c68a76124b727c736f431688 (diff)
downloadtdepim-b363d2579af0a11b77e698aed2e1021c2233b644.tar.gz
tdepim-b363d2579af0a11b77e698aed2e1021c2233b644.zip
Rename a number of libraries and executables to avoid conflicts with KDE4
Diffstat (limited to 'tderesources/Makefile.am')
-rw-r--r--tderesources/Makefile.am50
1 files changed, 50 insertions, 0 deletions
diff --git a/tderesources/Makefile.am b/tderesources/Makefile.am
new file mode 100644
index 00000000..c0ca6cd2
--- /dev/null
+++ b/tderesources/Makefile.am
@@ -0,0 +1,50 @@
+if include_exchange_SUBDIR
+EXCHANGE_SUBDIR=exchange
+endif
+
+if include_egroupware_SUBDIR
+EGROUPWARE_SUBDIR=egroupware
+endif
+
+if include_kolab_SUBDIR
+KOLAB_SUBDIR=kolab
+endif
+
+if include_slox_SUBDIR
+SLOX_SUBDIR=slox
+endif
+
+if include_groupwise_SUBDIR
+GROUPWISE_SUBDIR=groupwise
+endif
+
+if include_featureplan_SUBDIR
+FEATUREPLAN_SUBDIR=featureplan
+endif
+
+if include_groupdav_SUBDIR
+GROUPDAV_SUBDIR=groupdav
+endif
+
+if include_birthdays_SUBDIR
+BIRTHDAYS_SUBDIR=birthdays
+endif
+
+if include_newexchange_SUBDIR
+NEWEXCHANGE_SUBDIR=newexchange
+endif
+
+if include_scalix_SUBDIR
+SCALIX_SUBDIR=scalix
+endif
+
+if include_caldav_SUBDIR
+CALDAV_SUBDIR=caldav
+endif
+
+if include_carddav_SUBDIR
+CARDDAV_SUBDIR=carddav
+endif
+
+SUBDIRS = lib remote $(EGROUPWARE_SUBDIR) $(EXCHANGE_SUBDIR) $(KOLAB_SUBDIR) $(SLOX_SUBDIR) $(GROUPWISE_SUBDIR) $(FEATUREPLAN_SUBDIR) $(GROUPDAV_SUBDIR) $(BIRTHDAYS_SUBDIR) $(NEWEXCHANGE_SUBDIR) $(SCALIX_SUBDIR) $(CALDAV_SUBDIR) $(CARDDAV_SUBDIR)
+# SUBDIRS = remote egroupware $(EXCHANGE_SUBDIR) kolab slox groupwise featureplan