summaryrefslogtreecommitdiffstats
path: root/tderesources/scalix/knotes/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-07-12 16:15:10 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-07-14 19:26:10 +0200
commit3e868d844c44aab62fd1324e52872afd1f706cd3 (patch)
treeb3c06badd9b8f004ae92024d53c8bf15b8849cf0 /tderesources/scalix/knotes/CMakeLists.txt
parent9d2dbcebff2529124b4a522d3714b308548ee9ec (diff)
downloadtdepim-3e868d844c44aab62fd1324e52872afd1f706cd3.tar.gz
tdepim-3e868d844c44aab62fd1324e52872afd1f706cd3.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 0d3043b6308af148da06ac14c53defc4b1e7e138)
Diffstat (limited to 'tderesources/scalix/knotes/CMakeLists.txt')
-rw-r--r--tderesources/scalix/knotes/CMakeLists.txt15
1 files changed, 8 insertions, 7 deletions
diff --git a/tderesources/scalix/knotes/CMakeLists.txt b/tderesources/scalix/knotes/CMakeLists.txt
index 2c088be7..b5fcdf4f 100644
--- a/tderesources/scalix/knotes/CMakeLists.txt
+++ b/tderesources/scalix/knotes/CMakeLists.txt
@@ -25,16 +25,17 @@ link_directories(
##### other data ################################
-# FIXME this is a conflict
-
-install(
- FILES scalix.desktop
- DESTINATION ${SERVICES_INSTALL_DIR}/tderesources/knotes )
+tde_create_translated_desktop(
+ SOURCE scalix.desktop
+ DESTINATION ${SERVICES_INSTALL_DIR}/tderesources/knotes
+ PO_DIR tderesources-desktops
+)
install(
FILES ../uninstall.desktop
- RENAME scalix.desktop
- DESTINATION ${SERVICES_INSTALL_DIR}/tderesources/knotes )
+ RENAME imap.desktop
+ DESTINATION ${SERVICES_INSTALL_DIR}/tderesources/knotes
+)
##### knotes_scalix (module) ####################