summaryrefslogtreecommitdiffstats
path: root/akregator/src/mk4storage/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'akregator/src/mk4storage/Makefile.am')
-rw-r--r--akregator/src/mk4storage/Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/akregator/src/mk4storage/Makefile.am b/akregator/src/mk4storage/Makefile.am
new file mode 100644
index 00000000..4f2ebfae
--- /dev/null
+++ b/akregator/src/mk4storage/Makefile.am
@@ -0,0 +1,30 @@
+kde_module_LTLIBRARIES = libakregator_mk4storage_plugin.la
+
+SUBDIRS = metakit
+
+INCLUDES = \
+ -I$(top_srcdir)/akregator/src \
+ -I$(top_srcdir)/akregator/src/mk4storage/metakit/include \
+ $(all_includes)
+
+libakregator_mk4storage_plugin_la_LIBADD = \
+ $(top_builddir)/akregator/src/mk4storage/metakit/src/libmetakitlocal.la \
+ $(top_builddir)/akregator/src/librss/librsslocal.la \
+ ../libakregatorprivate.la \
+ $(LIB_KFILE) \
+ $(LIB_KDECORE)
+
+libakregator_mk4storage_plugin_la_LDFLAGS = \
+ $(KDE_PLUGIN) \
+ $(all_libraries)
+
+libakregator_mk4storage_plugin_la_SOURCES = feedstoragemk4impl.cpp \
+ storagemk4impl.cpp \
+ storagefactorymk4impl.cpp \
+ mk4plugin.cpp
+
+METASOURCES = AUTO
+
+kde_services_DATA = akregator_mk4storage_plugin.desktop
+
+kde_kcfg_DATA = mk4config.kcfg