summaryrefslogtreecommitdiffstats
path: root/certmanager/conf/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'certmanager/conf/CMakeLists.txt')
-rw-r--r--certmanager/conf/CMakeLists.txt55
1 files changed, 55 insertions, 0 deletions
diff --git a/certmanager/conf/CMakeLists.txt b/certmanager/conf/CMakeLists.txt
new file mode 100644
index 00000000..7b756d3a
--- /dev/null
+++ b/certmanager/conf/CMakeLists.txt
@@ -0,0 +1,55 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+add_definitions( -DLIBKLEOPATRA_NO_COMPAT )
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}/certmanager/lib/ui
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_SOURCE_DIR}/certmanager/lib
+ ${CMAKE_SOURCE_DIR}/certmanager/lib/ui
+ ${CMAKE_SOURCE_DIR}/libkdepim
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### other data ################################
+
+install( FILES
+ kleopatra_config_dirserv.desktop
+ kleopatra_config_appear.desktop
+ kleopatra_config_dnorder.desktop
+ DESTINATION ${SERVICES_INSTALL_DIR} )
+
+
+##### kcm_kleopatra (module) ####################
+
+tde_add_kpart( kcm_kleopatra AUTOMOC
+ SOURCES
+ dirservconfigpage.cpp appearanceconfigpage.cpp
+ appearanceconfigwidgetbase.ui dnorderconfigpage.cpp
+ appearanceconfigwidget.cpp
+ LINK kleopatra-shared
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)
+
+
+##### conf (static) #############################
+
+tde_add_library( conf STATIC AUTOMOC
+ SOURCES configuredialog.cpp
+)