summaryrefslogtreecommitdiffstats
path: root/kaddressbook/interfaces/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kaddressbook/interfaces/CMakeLists.txt')
-rw-r--r--kaddressbook/interfaces/CMakeLists.txt50
1 files changed, 50 insertions, 0 deletions
diff --git a/kaddressbook/interfaces/CMakeLists.txt b/kaddressbook/interfaces/CMakeLists.txt
new file mode 100644
index 00000000..67438ece
--- /dev/null
+++ b/kaddressbook/interfaces/CMakeLists.txt
@@ -0,0 +1,50 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_SOURCE_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### headers ###################################
+
+install( FILES
+ configurewidget.h contacteditorwidget.h core.h
+ extensionwidget.h xxport.h
+ DESTINATION ${INCLUDE_INSTALL_DIR}/kaddressbook )
+
+
+##### other data ################################
+
+install( FILES
+ kaddressbook_contacteditorwidget.desktop
+ kaddressbook_extension.desktop kaddressbook_xxport.desktop
+ DESTINATION ${SERVICETYPES_INSTALL_DIR} )
+
+
+##### kabinterfaces (shared) ####################
+
+tde_add_library( kabinterfaces SHARED AUTOMOC
+ SOURCES
+ configurewidget.cpp contacteditorwidget.cpp
+ core.cpp extensionwidget.cpp xxport.cpp
+ VERSION 1.0.0
+ LINK kabc-shared
+ DESTINATION ${LIB_INSTALL_DIR}
+)