summaryrefslogtreecommitdiffstats
path: root/kaddressbook/thumbnailcreator/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kaddressbook/thumbnailcreator/Makefile.am')
-rw-r--r--kaddressbook/thumbnailcreator/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/kaddressbook/thumbnailcreator/Makefile.am b/kaddressbook/thumbnailcreator/Makefile.am
new file mode 100644
index 00000000..2e37c009
--- /dev/null
+++ b/kaddressbook/thumbnailcreator/Makefile.am
@@ -0,0 +1,15 @@
+# kioslave to generate thumbnails for vCard and LDIF-Files in Konqueror
+INCLUDES = $(all_includes)
+
+kde_module_LTLIBRARIES = ldifvcardthumbnail.la
+
+ldifvcardthumbnail_la_SOURCES = ldifvcardcreator.cpp
+ldifvcardthumbnail_la_LDFLAGS = -module $(KDE_PLUGIN) $(KDE_RPATH) $(all_libraries) -no-undefined
+ldifvcardthumbnail_la_LIBADD = $(LIB_KDECORE) $(LIB_KABC) -lkdefx
+
+noinst_HEADERS = ldifvcardcreator.h
+
+METASOURCES = AUTO
+
+servicesdir = $(kde_servicesdir)
+services_DATA = ldifvcardthumbnail.desktop