summaryrefslogtreecommitdiffstats
path: root/kioslaves/opengroupware/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kioslaves/opengroupware/Makefile.am')
-rw-r--r--kioslaves/opengroupware/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/kioslaves/opengroupware/Makefile.am b/kioslaves/opengroupware/Makefile.am
new file mode 100644
index 00000000..bd410490
--- /dev/null
+++ b/kioslaves/opengroupware/Makefile.am
@@ -0,0 +1,17 @@
+INCLUDES = -I$(top_srcdir) -I$(top_srcdir)/kresources/opengroupware/soap \
+ $(all_includes)
+
+noinst_HEADERS = opengroupware.h
+
+METASOURCES = AUTO
+
+kdelnkdir = $(kde_servicesdir)
+kdelnk_DATA = opengroupware.protocol opengroupwares.protocol
+
+kde_module_LTLIBRARIES = kio_opengroupware.la
+
+kio_opengroupware_la_SOURCES = opengroupware.cpp webdavhandler.cpp
+kio_opengroupware_la_LIBADD = $(top_builddir)/libkcal/libkcal.la \
+ $(top_builddir)/libkdepim/libkdepim.la $(LIB_KIO)
+kio_opengroupware_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN)
+