summaryrefslogtreecommitdiffstats
path: root/kitchensync/libqopensync/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kitchensync/libqopensync/Makefile.am')
-rw-r--r--kitchensync/libqopensync/Makefile.am12
1 files changed, 4 insertions, 8 deletions
diff --git a/kitchensync/libqopensync/Makefile.am b/kitchensync/libqopensync/Makefile.am
index 772146a4..2e12df6c 100644
--- a/kitchensync/libqopensync/Makefile.am
+++ b/kitchensync/libqopensync/Makefile.am
@@ -2,20 +2,16 @@ INCLUDES = -I$(top_srcdir)/kitchensync/src \
-I$(top_srcdir)/kitchensync \
-I$(top_srcdir) \
$(OPENSYNC_CFLAGS) \
- $(GLIB_CFLAGS) \
+ $(OPENSYNCENGINE_CFLAGS) \
$(all_includes)
lib_LTLIBRARIES = libqopensync.la
-libqopensync_la_SOURCES = callbackhandler.cpp engine.cpp groupenv.cpp pluginenv.cpp filter.cpp group.cpp \
+libqopensync_la_SOURCES = callbackhandler.cpp conversion.cpp engine.cpp environment.cpp filter.cpp group.cpp \
member.cpp plugin.cpp result.cpp syncmapping.cpp syncupdates.cpp \
syncchange.cpp
-
-# FIXME: -no-undefined break the build for some unkown reason - libopensync broken?!
-#libqopensync_la_LDFLAGS = $(all_libraries) $(KDE_RPATH) -no-undefined
-libqopensync_la_LDFLAGS = $(all_libraries) $(KDE_RPATH)
-libqopensync_la_LIBADD = $(LIB_KDEUI) $(OPENSYNC_LIBS)
-
+libqopensync_la_LDFLAGS = $(all_libraries) $(KDE_RPATH) -no-undefined
+libqopensync_la_LIBADD = $(LIB_KDEUI) $(OPENSYNC_LIBS) $(OPENSYNCENGINE_LIBS)
METASOURCES = AUTO