summaryrefslogtreecommitdiffstats
path: root/kmobile/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kmobile/CMakeLists.txt')
-rw-r--r--kmobile/CMakeLists.txt14
1 files changed, 12 insertions, 2 deletions
diff --git a/kmobile/CMakeLists.txt b/kmobile/CMakeLists.txt
index 1c5cf0c0..43cff0a6 100644
--- a/kmobile/CMakeLists.txt
+++ b/kmobile/CMakeLists.txt
@@ -31,8 +31,18 @@ link_directories(
##### other data ################################
tde_install_icons( kmobile )
-install( FILES kmobile.desktop DESTINATION ${XDG_APPS_INSTALL_DIR} )
-install( FILES libkmobile.desktop DESTINATION ${SERVICETYPES_INSTALL_DIR} )
+
+tde_create_translated_desktop(
+ SOURCE kmobile.desktop
+ PO_DIR kmobile-desktops
+)
+
+tde_create_translated_desktop(
+ SOURCE libkmobile.desktop
+ DESTINATION ${SERVICETYPES_INSTALL_DIR}
+ PO_DIR kmobile-desktops
+)
+
install( FILES kmobileui.rc DESTINATION ${DATA_INSTALL_DIR}/kmobile )