summaryrefslogtreecommitdiffstats
path: root/kode/kxml_compiler/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kode/kxml_compiler/CMakeLists.txt')
-rw-r--r--kode/kxml_compiler/CMakeLists.txt30
1 files changed, 30 insertions, 0 deletions
diff --git a/kode/kxml_compiler/CMakeLists.txt b/kode/kxml_compiler/CMakeLists.txt
new file mode 100644
index 00000000..85592be8
--- /dev/null
+++ b/kode/kxml_compiler/CMakeLists.txt
@@ -0,0 +1,30 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_SOURCE_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### kxml_compiler (executable) ################
+
+tde_add_executable( kxml_compiler
+ SOURCES
+ parser.cpp creator.cpp kxml_compiler.cpp
+ LINK kode-shared
+ DESTINATION ${BIN_INSTALL_DIR}
+)