summaryrefslogtreecommitdiffstats
path: root/kontact/plugins/kaddressbook/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kontact/plugins/kaddressbook/Makefile.am')
-rw-r--r--kontact/plugins/kaddressbook/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/kontact/plugins/kaddressbook/Makefile.am b/kontact/plugins/kaddressbook/Makefile.am
new file mode 100644
index 00000000..a769f29d
--- /dev/null
+++ b/kontact/plugins/kaddressbook/Makefile.am
@@ -0,0 +1,18 @@
+INCLUDES = -I$(top_srcdir)/kontact/interfaces -I$(top_srcdir) $(all_includes)
+
+kde_module_LTLIBRARIES = libkontact_kaddressbookplugin.la
+libkontact_kaddressbookplugin_la_LDFLAGS = $(all_libraries) $(KDE_PLUGIN) -lkabc
+libkontact_kaddressbookplugin_la_LIBADD = $(top_builddir)/kontact/interfaces/libkpinterfaces.la $(top_builddir)/libkdepim/libkdepim.la
+
+libkontact_kaddressbookplugin_la_SOURCES = kaddressbook_plugin.cpp \
+ kaddressbookiface.stub \
+ kmailIface.stub
+
+METASOURCES = AUTO
+
+servicedir = $(kde_servicesdir)/kontact
+service_DATA = kaddressbookplugin.desktop
+
+kaddressbookiface_DIR = $(top_srcdir)/kaddressbook
+kmailIface_DIR = $(top_srcdir)/kmail
+kmailIface_DCOPIDLNG = true