summaryrefslogtreecommitdiffstats
path: root/kontact/plugins/karm/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kontact/plugins/karm/Makefile.am')
-rw-r--r--kontact/plugins/karm/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/kontact/plugins/karm/Makefile.am b/kontact/plugins/karm/Makefile.am
new file mode 100644
index 00000000..e3fb0227
--- /dev/null
+++ b/kontact/plugins/karm/Makefile.am
@@ -0,0 +1,16 @@
+INCLUDES = -I$(top_srcdir)/kontact/interfaces -I$(top_srcdir)/karm -I$(top_srcdir) $(all_includes)
+
+kde_module_LTLIBRARIES = libkontact_karm.la
+libkontact_karm_la_LDFLAGS = $(all_libraries) $(KDE_PLUGIN)
+libkontact_karm_la_LIBADD = $(top_builddir)/kontact/interfaces/libkpinterfaces.la
+
+libkontact_karm_la_SOURCES = karm_plugin.cpp karmdcopiface.stub
+
+METASOURCES = AUTO
+
+karmdcopiface_DIR = $(top_srcdir)/karm
+
+servicedir = $(kde_servicesdir)/kontact
+service_DATA = karmplugin.desktop
+
+DISTCLEANFILES = karmdcopiface.h karmdcopiface.stub