summaryrefslogtreecommitdiffstats
path: root/kontact/plugins/kitchensync/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kontact/plugins/kitchensync/Makefile.am')
-rw-r--r--kontact/plugins/kitchensync/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/kontact/plugins/kitchensync/Makefile.am b/kontact/plugins/kitchensync/Makefile.am
new file mode 100644
index 00000000..c6df9113
--- /dev/null
+++ b/kontact/plugins/kitchensync/Makefile.am
@@ -0,0 +1,14 @@
+INCLUDES = -I$(top_srcdir)/kontact/interfaces $(all_includes)
+
+kde_module_LTLIBRARIES = libkontact_kitchensync.la
+libkontact_kitchensync_la_LDFLAGS = $(all_libraries) $(KDE_PLUGIN)
+libkontact_kitchensync_la_LIBADD = $(top_builddir)/kontact/interfaces/libkpinterfaces.la
+
+libkontact_kitchensync_la_SOURCES = kitchensync_plugin.cpp
+
+METASOURCES = AUTO
+
+servicedir = $(kde_servicesdir)/kontact
+service_DATA = kitchensync.desktop
+
+kitchensynciface_DIR = $(top_srcdir)/kitchensync