summaryrefslogtreecommitdiffstats
path: root/kontact/plugins/knotes/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kontact/plugins/knotes/CMakeLists.txt')
-rw-r--r--kontact/plugins/knotes/CMakeLists.txt43
1 files changed, 43 insertions, 0 deletions
diff --git a/kontact/plugins/knotes/CMakeLists.txt b/kontact/plugins/knotes/CMakeLists.txt
new file mode 100644
index 00000000..db6a6c47
--- /dev/null
+++ b/kontact/plugins/knotes/CMakeLists.txt
@@ -0,0 +1,43 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+tde_import( knotes )
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}/../../interfaces
+ ${CMAKE_SOURCE_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### other data ################################
+
+install( FILES knotesplugin.desktop DESTINATION ${SERVICES_INSTALL_DIR}/kontact )
+install( FILES knotes_part.rc DESTINATION ${DATA_INSTALL_DIR}/knotes )
+
+
+##### libkontact_knotesplugin (module) ##########
+
+set( KDE3_DCOPIDL_EXECUTABLE ${KDE3_DCOPIDLNG_EXECUTABLE} )
+
+tde_add_kpart( libkontact_knotesplugin AUTOMOC
+ SOURCES
+ knotes_plugin.cpp knotes_part.cpp summarywidget.cpp knotetip.cpp
+ ${CMAKE_SOURCE_DIR}/knotes/KNotesIface.skel
+ LINK kpinterfaces-shared knotes-shared
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)