summaryrefslogtreecommitdiffstats
path: root/kontact/plugins/knotes/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kontact/plugins/knotes/Makefile.am')
-rw-r--r--kontact/plugins/knotes/Makefile.am23
1 files changed, 23 insertions, 0 deletions
diff --git a/kontact/plugins/knotes/Makefile.am b/kontact/plugins/knotes/Makefile.am
new file mode 100644
index 00000000..4a3b1710
--- /dev/null
+++ b/kontact/plugins/knotes/Makefile.am
@@ -0,0 +1,23 @@
+INCLUDES = -I$(top_srcdir)/kontact/interfaces -I$(top_srcdir) $(all_includes)
+
+kde_module_LTLIBRARIES = libkontact_knotesplugin.la
+libkontact_knotesplugin_la_LDFLAGS = $(all_libraries) $(KDE_PLUGIN)
+libkontact_knotesplugin_la_LIBADD = $(top_builddir)/kontact/interfaces/libkpinterfaces.la \
+ $(LIB_KPARTS) $(top_builddir)/libkdepim/libkdepim.la \
+ $(top_builddir)/libkcal/libkcal.la -lkresources -lkdeprint \
+ $(top_builddir)/knotes/libknotesresources.la \
+ $(top_builddir)/knotes/libknoteseditor.la \
+ $(top_builddir)/knotes/libknotesprinting.la
+
+libkontact_knotesplugin_la_SOURCES = knotes_plugin.cpp knotes_part.cpp summarywidget.cpp \
+ knotetip.cpp KNotesIface.skel
+
+METASOURCES = AUTO
+
+servicedir = $(kde_servicesdir)/kontact
+service_DATA = knotesplugin.desktop
+
+partdir = $(kde_datadir)/knotes
+part_DATA = knotes_part.rc
+
+KNotesIface_DIR = $(top_srcdir)/knotes