summaryrefslogtreecommitdiffstats
path: root/korganizer/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'korganizer/CMakeLists.txt')
-rw-r--r--korganizer/CMakeLists.txt22
1 files changed, 14 insertions, 8 deletions
diff --git a/korganizer/CMakeLists.txt b/korganizer/CMakeLists.txt
index a5e8aff1..00bc3577 100644
--- a/korganizer/CMakeLists.txt
+++ b/korganizer/CMakeLists.txt
@@ -53,21 +53,27 @@ link_directories(
tde_install_icons( )
-install( FILES
- korganizer.desktop
- DESTINATION ${XDG_APPS_INSTALL_DIR} )
+tde_create_translated_desktop(
+ SOURCE korganizer.desktop
+ PO_DIR korganizer-desktops
+)
-install( FILES
- dcopcalendar.desktop
- DESTINATION ${SERVICETYPES_INSTALL_DIR} )
+tde_create_translated_desktop(
+ SOURCE dcopcalendar.desktop
+ DESTINATION ${SERVICETYPES_INSTALL_DIR}
+ PO_DIR korganizer-desktops
+)
-install( FILES
+tde_create_translated_desktop(
+ SOURCE
korganizer_configmain.desktop korganizer_configtime.desktop
korganizer_configviews.desktop korganizer_configcolors.desktop
korganizer_configfonts.desktop korganizer_configplugins.desktop
korganizer_configgroupscheduling.desktop korganizer_configfreebusy.desktop
korganizer_configdesignerfields.desktop webcal.protocol
- DESTINATION ${SERVICES_INSTALL_DIR} )
+ DESTINATION ${SERVICES_INSTALL_DIR}
+ PO_DIR korganizer-desktops
+)
install( FILES
uninstall.desktop