summaryrefslogtreecommitdiffstats
path: root/korganizer/plugins/exchange/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'korganizer/plugins/exchange/Makefile.am')
-rw-r--r--korganizer/plugins/exchange/Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/korganizer/plugins/exchange/Makefile.am b/korganizer/plugins/exchange/Makefile.am
new file mode 100644
index 00000000..39290aad
--- /dev/null
+++ b/korganizer/plugins/exchange/Makefile.am
@@ -0,0 +1,27 @@
+# $Id$
+
+SUBDIRS=
+
+METASOURCES = AUTO
+
+INCLUDES = -I$(top_srcdir)/korganizer/interfaces \
+ -I$(top_srcdir)/libkpimexchange/core -I$(top_builddir)/libkpimexchange/core \
+ -I$(top_srcdir) \
+ $(all_includes)
+
+kde_module_LTLIBRARIES = libkorg_exchange.la
+
+libkorg_exchange_la_SOURCES = exchange.cpp exchangedialog.cpp exchangeconfig.cpp
+libkorg_exchange_la_LDFLAGS = -module $(KDE_PLUGIN) $(KDE_RPATH) $(all_libraries)
+libkorg_exchange_la_LIBADD = $(top_builddir)/korganizer/libkorganizer.la \
+ $(top_builddir)/libkpimexchange/libkpimexchange.la \
+ $(LIB_KDEUI) $(LIB_KPARTS)
+
+noinst_HEADERS = exchange.h exchangedialog.h exchangeconfig.h
+
+servicedir = $(kde_servicesdir)/korganizer
+service_DATA = exchange.desktop
+
+rcdir = $(kde_datadir)/korganizer/plugins
+rc_DATA = exchangeui.rc
+