summaryrefslogtreecommitdiffstats
path: root/kresources/birthdays/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kresources/birthdays/CMakeLists.txt')
-rw-r--r--kresources/birthdays/CMakeLists.txt45
1 files changed, 45 insertions, 0 deletions
diff --git a/kresources/birthdays/CMakeLists.txt b/kresources/birthdays/CMakeLists.txt
new file mode 100644
index 00000000..244226ee
--- /dev/null
+++ b/kresources/birthdays/CMakeLists.txt
@@ -0,0 +1,45 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}/kaddressbook/common
+ ${CMAKE_SOURCE_DIR}
+ ${CMAKE_SOURCE_DIR}/kaddressbook/common
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### headers ###################################
+
+install( FILES
+ resourcekabc.h resourcekabcconfig.h
+ DESTINATION ${INCLUDE_INSTALL_DIR}/libkcal )
+
+
+##### other data ################################
+
+install( FILES kabc.desktop DESTINATION ${SERVICES_INSTALL_DIR}/kresources/kcal )
+
+
+##### kcal_kabc (module) #######################
+
+tde_add_kpart( kcal_kabc AUTOMOC
+ SOURCES
+ resourcekabc.cpp resourcekabcconfig.cpp
+ LINK kabcommon-static kdepim-shared
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)