summaryrefslogtreecommitdiffstats
path: root/ktnef/gui/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'ktnef/gui/CMakeLists.txt')
-rw-r--r--ktnef/gui/CMakeLists.txt43
1 files changed, 43 insertions, 0 deletions
diff --git a/ktnef/gui/CMakeLists.txt b/ktnef/gui/CMakeLists.txt
new file mode 100644
index 00000000..2f5df39e
--- /dev/null
+++ b/ktnef/gui/CMakeLists.txt
@@ -0,0 +1,43 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+add_subdirectory( pics )
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_SOURCE_DIR}/ktnef
+ ${CMAKE_SOURCE_DIR}/libkdepim
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### other data ################################
+
+install( FILES ktnef.desktop DESTINATION ${XDG_APPS_INSTALL_DIR} )
+install( FILES ktnefui.rc DESTINATION ${DATA_INSTALL_DIR}/ktnef )
+install( FILES ms-tnef.desktop DESTINATION ${MIME_INSTALL_DIR}/application )
+
+
+##### ktnef (executable) ########################
+
+tde_add_executable( ktnef AUTOMOC
+ SOURCES
+ ktnefmain.cpp ktnefview.cpp attachpropertydialogbase.ui
+ attachpropertydialog.cpp messagepropertydialog.cpp
+ qwmf.cpp main.cpp
+ LINK ktnef-shared
+ DESTINATION ${BIN_INSTALL_DIR}
+)