summaryrefslogtreecommitdiffstats
path: root/libemailfunctions/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libemailfunctions/Makefile.am')
-rw-r--r--libemailfunctions/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/libemailfunctions/Makefile.am b/libemailfunctions/Makefile.am
new file mode 100644
index 00000000..e424e947
--- /dev/null
+++ b/libemailfunctions/Makefile.am
@@ -0,0 +1,19 @@
+INCLUDES = $(all_includes) -I$(srcdir)/../libkmime/
+
+noinst_LTLIBRARIES = libemailfunctions.la
+libemailfunctions_la_SOURCES = email.cpp idmapper.cpp kasciistricmp.cpp \
+ kasciistringtools.cpp \
+ networkstatus.cpp networkstatus.skel
+libemailfunctions_la_LDFLAGS = $(all_libraries) -no-undefined
+## Since this is a noinst library, in case of --enable-closure we need
+## to link it explicitly to the libraries that it uses.
+libemailfunctions_la_LIBADD = ../libkmime/libkmime.la $(LIB_QT) $(LIB_KDECORE)
+
+emailfunctionsincludedir = $(includedir)/libemailfunctions
+emailfunctionsinclude_HEADERS = idmapper.h
+
+METASOURCES = AUTO
+
+# No messages target. Those files are part of libkdepim.pot.
+
+include $(top_srcdir)/admin/Doxyfile.am