summaryrefslogtreecommitdiffstats
path: root/libemailfunctions/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libemailfunctions/tests/Makefile.am')
-rw-r--r--libemailfunctions/tests/Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/libemailfunctions/tests/Makefile.am b/libemailfunctions/tests/Makefile.am
new file mode 100644
index 00000000..95874de9
--- /dev/null
+++ b/libemailfunctions/tests/Makefile.am
@@ -0,0 +1,13 @@
+AM_CPPFLAGS = -I$(top_srcdir)/libemailfunctions $(all_includes)
+LDADD = ../libemailfunctions.la ../../libkmime/libkmime.la $(LIB_KDECORE)
+
+check_PROGRAMS = testidmapper testemail
+TESTS = testemail
+
+testidmapper_LDFLAGS = $(all_libraries) $(KDE_RPATH)
+testidmapper_SOURCES = testidmapper.cpp
+
+testemail_LDFLAGS = $(all_libraries) $(KDE_RPATH)
+testemail_SOURCES = testemail.cpp
+
+METASOURCES = AUTO