summaryrefslogtreecommitdiffstats
path: root/libkcal/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'libkcal/CMakeLists.txt')
-rw-r--r--libkcal/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/libkcal/CMakeLists.txt b/libkcal/CMakeLists.txt
index 2a730d11..d4ee0edb 100644
--- a/libkcal/CMakeLists.txt
+++ b/libkcal/CMakeLists.txt
@@ -35,6 +35,23 @@ link_directories(
)
+##### headers ###################################
+
+install( FILES
+ alarm.h attachment.h attendee.h calendar.h calendarlocal.h
+ calendarnull.h calendarresources.h calfilter.h calformat.h
+ calstorage.h customproperties.h dndfactory.h duration.h event.h
+ exceptions.h filestorage.h freebusy.h htmlexportsettings.h
+ htmlexport.h icaldrag.h icalformat.h incidencebase.h incidence.h
+ incidenceformatter.h calhelper.h calselectdialog.h journal.h
+ kcalversion.h listbase.h period.h person.h qtopiaformat.h
+ recurrencerule.h recurrence.h resourcecached.h resourcecalendar.h
+ resourcelocalconfig.h resourcelocaldirconfig.h resourcelocaldir.h
+ resourcelocal.h scheduler.h libkcal_export.h todo.h vcaldrag.h
+ vcalformat.h attachmenthandler.h
+ DESTINATION ${INCLUDE_INSTALL_DIR}/libkcal )
+
+
##### other data ################################
install( FILES local.desktop localdir.desktop DESTINATION ${SERVICES_INSTALL_DIR}/kresources/kcal )