summaryrefslogtreecommitdiffstats
path: root/libkpimexchange/core/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'libkpimexchange/core/CMakeLists.txt')
-rw-r--r--libkpimexchange/core/CMakeLists.txt45
1 files changed, 45 insertions, 0 deletions
diff --git a/libkpimexchange/core/CMakeLists.txt b/libkpimexchange/core/CMakeLists.txt
new file mode 100644
index 00000000..fde8a6b4
--- /dev/null
+++ b/libkpimexchange/core/CMakeLists.txt
@@ -0,0 +1,45 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+tde_import( libkmime )
+tde_import( ktnef )
+tde_import( libkcal )
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_SOURCE_DIR}
+ ${CMAKE_SOURCE_DIR}/libkdepim
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### headers ###################################
+
+install( FILES
+ exchangeclient.h exchangeaccount.h
+ DESTINATION ${INCLUDE_INSTALL_DIR}/kdepim )
+
+
+##### kpimexchange (shared) #####################
+
+tde_add_library( kpimexchange SHARED AUTOMOC
+ SOURCES
+ exchangeclient.cpp exchangeaccount.cpp exchangedownload.cpp exchangeupload.cpp
+ exchangedelete.cpp utils.cpp exchangeprogress.cpp exchangemonitor.cpp
+ VERSION 1.0.0
+ LINK kcal-shared
+ DESTINATION ${LIB_INSTALL_DIR}
+)