summaryrefslogtreecommitdiffstats
path: root/libksieve/parser/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'libksieve/parser/CMakeLists.txt')
-rw-r--r--libksieve/parser/CMakeLists.txt25
1 files changed, 25 insertions, 0 deletions
diff --git a/libksieve/parser/CMakeLists.txt b/libksieve/parser/CMakeLists.txt
new file mode 100644
index 00000000..526bb168
--- /dev/null
+++ b/libksieve/parser/CMakeLists.txt
@@ -0,0 +1,25 @@
+#################################################
+#
+# (C) 2010-2011 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_SOURCE_DIR}/libksieve
+ ${CMAKE_SOURCE_DIR}/libkdepim
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+
+##### ksieve_parser (static) ####################
+
+tde_add_library( ksieve_parser STATIC_PIC
+ SOURCES utf8validator.cpp lexer.cpp parser.cpp
+)