summaryrefslogtreecommitdiffstats
path: root/tdefile-plugins/rfc822/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tdefile-plugins/rfc822/Makefile.am')
-rw-r--r--tdefile-plugins/rfc822/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/tdefile-plugins/rfc822/Makefile.am b/tdefile-plugins/rfc822/Makefile.am
new file mode 100644
index 00000000..f7cf8969
--- /dev/null
+++ b/tdefile-plugins/rfc822/Makefile.am
@@ -0,0 +1,22 @@
+## Makefile.am for rfc822 file meta info plugin
+
+# set the include path for X, qt and KDE
+INCLUDES = $(all_includes)
+
+# these are the headers for your project
+noinst_HEADERS = tdefile_rfc822.h
+
+kde_module_LTLIBRARIES = tdefile_rfc822.la
+
+tdefile_rfc822_la_SOURCES = tdefile_rfc822.cpp
+tdefile_rfc822_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN)
+tdefile_rfc822_la_LIBADD = $(LIB_KSYCOCA)
+
+# let automoc handle all of the meta source files (moc)
+METASOURCES = AUTO
+
+messages: rc.cpp
+ $(XGETTEXT) tdefile_rfc822.cpp -o $(podir)/tdefile_rfc822.pot
+
+services_DATA = tdefile_rfc822.desktop
+servicesdir = $(kde_servicesdir)