summaryrefslogtreecommitdiffstats
path: root/tderesources/kolab/kcal/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tderesources/kolab/kcal/Makefile.am')
-rw-r--r--tderesources/kolab/kcal/Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/tderesources/kolab/kcal/Makefile.am b/tderesources/kolab/kcal/Makefile.am
new file mode 100644
index 00000000..a2502791
--- /dev/null
+++ b/tderesources/kolab/kcal/Makefile.am
@@ -0,0 +1,27 @@
+METASOURCES = AUTO
+
+INCLUDES = -I$(top_srcdir)/tderesources/kolab/shared -I$(top_srcdir) \
+ -I$(top_builddir)/libtdepim $(all_includes)
+
+# The kolab wizard links to this library too
+lib_LTLIBRARIES = libkcalkolab.la
+
+libkcalkolab_la_SOURCES = incidence.cpp event.cpp task.cpp journal.cpp resourcekolab.cpp
+libkcalkolab_la_LDFLAGS = $(all_libraries) -no-undefined
+libkcalkolab_la_LIBADD = $(top_builddir)/libkcal/libkcal.la \
+ $(top_builddir)/tderesources/kolab/shared/libresourcekolabshared.la \
+ -ltderesources
+
+kde_module_LTLIBRARIES = kcal_kolab.la
+
+kcal_kolab_la_SOURCES = resourcekolab_plugin.cpp
+kcal_kolab_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN) -no-undefined
+kcal_kolab_la_LIBADD = libkcalkolab.la
+
+servicedir = $(kde_servicesdir)/tderesources/kcal
+service_DATA = kolab.desktop
+
+install-data-local: $(srcdir)/../uninstall.desktop
+ $(mkinstalldirs) $(DESTDIR)$(servicedir)
+ $(INSTALL_DATA) $(srcdir)/../uninstall.desktop $(DESTDIR)$(servicedir)/imap.desktop
+