summaryrefslogtreecommitdiffstats
path: root/tderesources/newexchange/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tderesources/newexchange/Makefile.am')
-rw-r--r--tderesources/newexchange/Makefile.am45
1 files changed, 45 insertions, 0 deletions
diff --git a/tderesources/newexchange/Makefile.am b/tderesources/newexchange/Makefile.am
new file mode 100644
index 00000000..62a99b47
--- /dev/null
+++ b/tderesources/newexchange/Makefile.am
@@ -0,0 +1,45 @@
+INCLUDES = -I$(top_srcdir) -I$(top_srcdir)/tderesources/lib \
+ -I$(top_builddir)/tderesources/lib $(all_includes)
+
+lib_LTLIBRARIES = libkabc_newexchange.la libkcal_newexchange.la
+noinst_LTLIBRARIES = libknewexchange.la
+
+libknewexchange_la_SOURCES = exchangeglobals.cpp exchangeconvertercalendar.cpp exchangeconvertercontact.cpp
+
+libkcal_newexchange_la_SOURCES = exchangecalendaradaptor.cpp kcal_resourceexchange.cpp
+libkcal_newexchange_la_LDFLAGS = $(KDE_RPATH) $(all_libraries) \
+ -version-info 1:0:0 -no-undefined
+libkcal_newexchange_la_LIBADD = \
+ libknewexchange.la ../lib/libkgroupwaredav.la \
+ $(top_builddir)/libkcal/libkcal.la $(top_builddir)/libtdepim/libtdepim.la \
+ -lkabc
+
+libkabc_newexchange_la_SOURCES = kabc_resourceexchange.cpp exchangeaddressbookadaptor.cpp
+libkabc_newexchange_la_LDFLAGS = $(KDE_RPATH) $(all_libraries) \
+ -version-info 1:0:0 -no-undefined
+libkabc_newexchange_la_LIBADD = \
+ libknewexchange.la ../lib/libkgroupwaredav.la \
+ $(top_builddir)/libkcal/libkcal.la $(top_builddir)/libtdepim/libtdepim.la \
+ -lkabc
+
+kde_module_LTLIBRARIES = kcal_newexchange.la kabc_newexchange.la
+
+kcal_newexchange_la_SOURCES = kcal_resourceexchange_plugin.cpp
+kcal_newexchange_la_LDFLAGS = $(all_libraries) -module -no-undefined $(KDE_PLUGIN)
+kcal_newexchange_la_LIBADD = libkcal_newexchange.la
+
+kabc_newexchange_la_SOURCES = kabc_resourceexchange_plugin.cpp
+kabc_newexchange_la_LDFLAGS = $(all_libraries) -module -no-undefined $(KDE_PLUGIN)
+kabc_newexchange_la_LIBADD = libkabc_newexchange.la
+
+
+kcal_servicedir = $(kde_servicesdir)/tderesources/kcal
+kcal_service_DATA = kcal_newexchange.desktop
+
+kabc_servicedir = $(kde_servicesdir)/tderesources/kabc
+kabc_service_DATA = kabc_newexchange.desktop
+
+METASOURCES = AUTO
+
+kcal_resourceexchange.lo kabc_resourceexchange.lo: ../lib/tderesources_groupwareprefs.h
+