summaryrefslogtreecommitdiffstats
path: root/tderesources/slox/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tderesources/slox/Makefile.am')
-rw-r--r--tderesources/slox/Makefile.am51
1 files changed, 51 insertions, 0 deletions
diff --git a/tderesources/slox/Makefile.am b/tderesources/slox/Makefile.am
new file mode 100644
index 00000000..7189d633
--- /dev/null
+++ b/tderesources/slox/Makefile.am
@@ -0,0 +1,51 @@
+INCLUDES = -I$(top_srcdir) $(all_includes)
+
+
+lib_LTLIBRARIES = libkslox.la libkabc_slox.la libkcal_slox.la
+
+libkslox_la_SOURCES = sloxaccounts.cpp webdavhandler.cpp \
+ sloxfolder.cpp sloxfoldermanager.cpp \
+ sloxfolderdialog.cpp sloxbase.cpp
+libkslox_la_LDFLAGS = $(all_libraries)
+libkslox_la_LIBADD = $(top_builddir)/libkcal/libkcal.la \
+ $(top_builddir)/libtdepim/libtdepim.la
+
+libkcal_slox_la_SOURCES = kcalresourceslox.cpp kcalresourcesloxconfig.cpp \
+ kcalsloxprefs.kcfgc
+libkcal_slox_la_LDFLAGS = $(all_libraries)
+libkcal_slox_la_LIBADD = libkslox.la $(top_builddir)/libkcal/libkcal.la
+
+libkabc_slox_la_SOURCES = kabcresourceslox.cpp kabcresourcesloxconfig.cpp \
+ kabcsloxprefs.kcfgc
+libkabc_slox_la_LDFLAGS = $(all_libraries)
+libkabc_slox_la_LIBADD = libkslox.la -lkabc
+
+
+kde_module_LTLIBRARIES = kcal_slox.la kabc_slox.la
+
+kcal_slox_la_SOURCES = kcalresourceslox_plugin.cpp
+kcal_slox_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN)
+kcal_slox_la_LIBADD = libkcal_slox.la
+
+kabc_slox_la_SOURCES = kabcresourceslox_plugin.cpp
+kabc_slox_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN)
+kabc_slox_la_LIBADD = libkabc_slox.la
+
+
+EXTRA_PROGRAMS = testsloxaccounts
+
+testsloxaccounts_LDFLAGS = $(all_libraries) $(KDE_RPATH) $(LIB_QT) -lDCOP $(LIB_TDECORE) $(LIB_TDEUI) -ltdefx $(LIB_KIO) -ltdetexteditor
+testsloxaccounts_LDADD = libkslox.la
+testsloxaccounts_SOURCES = testsloxaccounts.cpp
+
+
+kcal_servicedir = $(kde_servicesdir)/tderesources/kcal
+kcal_service_DATA = kcal_slox.desktop kcal_ox.desktop
+
+kabc_servicedir = $(kde_servicesdir)/tderesources/kabc
+kabc_service_DATA = kabc_slox.desktop kabc_ox.desktop
+
+METASOURCES = AUTO
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/kabc_slox.pot