Subject: OD outputs the hex from right to left?...hex dump utility...

From: "Dave Arnold" <[email-masked]>
Date: Sat, 1 Jul 2000 19:44:51 -0700

hi Tim,

I just realized that the od dump utility is dumping the hex values
from right to left and then dumping the ascii values from left to right.

This makes it very hard to read.  Is there a flag or option to make the
output of ascii and hex columns to be in the same order?

here's a sample output.

      000000 00000009 34333231 bf003635 00000078
              ht nul nul nul   1   2   3   4   5   6 nul   ?   x nul nul nul
      000010 454c4f53 4f525443 5343494e 0000ea00
               S   O   L   E   C   T   R   O   N   I   C   S nul   j nul nul

I like the output to appear like so:

      000010 534f4c45 4354524f 4e494353 00ea0000
               S   O   L   E   C   T   R   O   N   I   C   S nul   j nul nul

or even better like this:(all on one line, only letters and number seen on
ascii view and a '.' for everything else)
(also all on one line is much more readable)

      000010       000010 534f4c45 4354524f 4e494353 00ea0000
SOLECTRONICS.J..

Any help or suggestions on this would be very welcomed.

/dAVe

-----Original Message-----
From: Tim Prince <[email-masked]>
To: Dave Arnold <[email-masked]>; [email-masked]
<[email-masked]>
Cc: mail and news <[email-masked]>
Date: Saturday, July 01, 2000 6:35 PM
Subject: Re: looking for good hex dump utility...

>If od doesn't match your description, it might help if you would
>clarify.
>
>Tim Prince
>----- Original Message -----
>From: "Dave Arnold" <[email-masked]>
>To: <[email-masked]>
>Cc: "mail and news" <[email-masked]>
>Sent: Saturday, July 01, 2000 6:10 PM
>Subject: looking for good hex dump utility...
>
>
>> hi,
>>
>> can anyone recommend a good, simple hex dump utility that's
>> available with very portable source code in c/c++ or java which I can
>> build and use on any of the variety of GNU supported platforms?
>>
>> I just want something that I can take with me from one computer
>> to the next as needed without having to find one for each platform
>> as I go.
>>
>> Just would like be able to dump file contents and see hex and ascii
>> values line by line 16bytes at a time with byte address in hex next
>> to each line.
>>
>> thanks,
>> /dAVe
>>
>>
>
>
>
>--
>Want to unsubscribe from this list?
>Send a message to [email-masked]
>

--
Want to unsubscribe from this list?
Send a message to [email-masked]

---

From: "Doug Wyatt" <[email-masked]>
Date: Sat, 1 Jul 2000 23:17:21 -0500

Hi,

I would suggest either of the following:

1.  your requirements are so narrow and specific you could probably
     write a tool to do what you want, in C or Perl, in less than an hour.

2.  use a big-endian computer, so the bytes are in the order you want
     them (e.g. MC 68xxxx, or  the pending IA-64).

Regards,
Doug Wyatt