summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexander Golubev <fatzer2@gmail.com>2013-09-20 03:26:52 +0200
committerSlávek Banko <slavek.banko@axis.cz>2013-09-20 03:26:52 +0200
commite113ed917ca8d86e607c7fc70accd681cfefb0a4 (patch)
tree3a26e5528d7850bab5c7f8ba856588a8795e0659 /CMakeLists.txt
parent06c56ee1e11121a033e9d4670c50ef2f893ba511 (diff)
downloadtdepowersave-e113ed917ca8d86e607c7fc70accd681cfefb0a4.tar.gz
tdepowersave-e113ed917ca8d86e607c7fc70accd681cfefb0a4.zip
Fix cmake support for translations
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 9 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7bd0677..bd8936e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -35,6 +35,13 @@ include( TDESetupPaths )
tde_setup_paths( )
+##### user requested modules ####################
+
+option( BUILD_ALL "Build all" OFF )
+option( BUILD_DOC "Build doc" ${BUILD_ALL} )
+option( BUILD_TRANSLATIONS "Build translations" ${BUILD_ALL} )
+
+
##### configure checks ##########################
include( ConfigureChecks.cmake )
@@ -54,8 +61,8 @@ set( CMAKE_MODULE_LINKER_FLAGS "-Wl,--no-undefined" )
##### source directories ########################
add_subdirectory( src )
-add_subdirectory( doc )
-add_subdirectory( po )
+tde_conditional_add_subdirectory( BUILD_DOC doc )
+tde_conditional_add_subdirectory( BUILD_TRANSLATIONS po )
##### write configure files #####################