summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in209
1 files changed, 93 insertions, 116 deletions
diff --git a/configure.in b/configure.in
index dfdde39..f6a7f61 100644
--- a/configure.in
+++ b/configure.in
@@ -40,16 +40,17 @@ dnl Perform program name transformation
AC_ARG_PROGRAM
dnl Automake doc recommends to do this only here. (Janos)
-AM_INIT_AUTOMAKE(tderadio-0.1.1.1~20061112, "3.5.5") dnl searches for some needed programs
+AM_INIT_AUTOMAKE(tderadio, "3.5.10") dnl searches for some needed programs
KDE_SET_PREFIX
dnl generate the config header
-AM_CONFIG_HEADER(config.h) dnl at the distribution this done
+AC_CONFIG_HEADER(config.h) dnl at the distribution this done
dnl Checks for programs.
AC_PROG_CC
AC_PROG_CXX
+TDE_CXX_COMPILE_STDCXX(11)
AC_CHECK_COMPILERS
AC_ENABLE_SHARED(yes)
AC_ENABLE_STATIC(no)
@@ -59,43 +60,12 @@ dnl for NLS support. Call them in this order!
dnl WITH_NLS is for the po files
AM_KDE_WITH_NLS
-KDE_USE_QT(3.3)
+KDE_USE_QT(3.2)
AC_PATH_KDE
dnl =======================================================
dnl FILE: configure.in.in
dnl =======================================================
-#MIN_CONFIG(3.3)
-# Define a symbol, to know that we're compiling WITH kde. (for apps that
-# can compile without KDE, optionally)
-AM_CONDITIONAL(KDE_INSTALLED, test "$have_kde" = "yes")
-
-dnl Checks for header files.
-AC_HEADER_DIRENT
-AC_HEADER_STDC
-AC_CHECK_HEADERS(fcntl.h sys/time.h sys/stat.h stdint.h)
-AC_CHECK_HEADERS(sys/cdefs.h fnmatch.h sysent.h strings.h paths.h)
-AC_CHECK_HEADERS(utmp.h sys/param.h linux/tcp.h sys/proc.h)
-
-dnl Checks for typedefs, structures, and compiler characteristics.
-AC_HEADER_TIME
-
-AC_C_LONG_DOUBLE
-
-dnl Checks for library functions.
-KDE_CHECK_DLOPEN
-AC_CHECK_FUNCS(socket fabsl strdup vsnprintf re_comp flock)
-AC_CHECK_SETENV
-AC_CHECK_UNSETENV
-AC_CHECK_GETDOMAINNAME
-AC_CHECK_GETHOSTNAME
-AM_PROG_LEX
-LFLAGS="-o${LEX_OUTPUT_ROOT}.c"
-AC_SUBST(LFLAGS)
-dnl =======================================================
-dnl FILE: ./tderadio3/configure.in.in
-dnl =======================================================
-
#MIN_CONFIG(3.2)
@@ -307,85 +277,92 @@ dnl ----------------------------------------------------------------------
dnl apidox
KDE_INIT_DOXYGEN([The TDERadio API Reference], [Version $VERSION])
KDE_CREATE_SUBDIRSLIST
-AM_CONDITIONAL(tderadio3_SUBDIR_included, test "x$tderadio3_SUBDIR_included" = xyes)
AC_CONFIG_FILES([ Makefile ])
-AC_CONFIG_FILES([ tderadio3/Makefile ])
-AC_CONFIG_FILES([ tderadio3/convert-presets/Makefile ])
-AC_CONFIG_FILES([ tderadio3/convert-presets/po/Makefile ])
-AC_CONFIG_FILES([ tderadio3/icons/Makefile ])
-AC_CONFIG_FILES([ tderadio3/plugins/Makefile ])
-AC_CONFIG_FILES([ tderadio3/plugins/alsa-sound/Makefile ])
-AC_CONFIG_FILES([ tderadio3/plugins/alsa-sound/icons/Makefile ])
-AC_CONFIG_FILES([ tderadio3/plugins/alsa-sound/po/Makefile ])
-AC_CONFIG_FILES([ tderadio3/plugins/gui-docking-menu/Makefile ])
-AC_CONFIG_FILES([ tderadio3/plugins/gui-docking-menu/po/Makefile ])
-AC_CONFIG_FILES([ tderadio3/plugins/gui-error-log/Makefile ])
-AC_CONFIG_FILES([ tderadio3/plugins/gui-error-log/po/Makefile ])
-AC_CONFIG_FILES([ tderadio3/plugins/gui-quickbar/Makefile ])
-AC_CONFIG_FILES([ tderadio3/plugins/gui-quickbar/po/Makefile ])
-AC_CONFIG_FILES([ tderadio3/plugins/gui-standard-display/Makefile ])
-AC_CONFIG_FILES([ tderadio3/plugins/gui-standard-display/po/Makefile ])
-AC_CONFIG_FILES([ tderadio3/plugins/lirc/Makefile ])
-AC_CONFIG_FILES([ tderadio3/plugins/lirc/po/Makefile ])
-AC_CONFIG_FILES([ tderadio3/plugins/oss-sound/Makefile ])
-AC_CONFIG_FILES([ tderadio3/plugins/oss-sound/icons/Makefile ])
-AC_CONFIG_FILES([ tderadio3/plugins/oss-sound/po/Makefile ])
-AC_CONFIG_FILES([ tderadio3/plugins/radio/Makefile ])
-AC_CONFIG_FILES([ tderadio3/plugins/radio/po/Makefile ])
-AC_CONFIG_FILES([ tderadio3/plugins/recording/Makefile ])
-AC_CONFIG_FILES([ tderadio3/plugins/recording/icons/Makefile ])
-AC_CONFIG_FILES([ tderadio3/plugins/recording/po/Makefile ])
-AC_CONFIG_FILES([ tderadio3/plugins/soundserver/Makefile ])
-AC_CONFIG_FILES([ tderadio3/plugins/soundserver/po/Makefile ])
-AC_CONFIG_FILES([ tderadio3/plugins/streaming/Makefile ])
-AC_CONFIG_FILES([ tderadio3/plugins/streaming/icons/Makefile ])
-AC_CONFIG_FILES([ tderadio3/plugins/streaming/po/Makefile ])
-AC_CONFIG_FILES([ tderadio3/plugins/timecontrol/Makefile ])
-AC_CONFIG_FILES([ tderadio3/plugins/timecontrol/icons/Makefile ])
-AC_CONFIG_FILES([ tderadio3/plugins/timecontrol/po/Makefile ])
-AC_CONFIG_FILES([ tderadio3/plugins/timeshifter/Makefile ])
-AC_CONFIG_FILES([ tderadio3/plugins/timeshifter/icons/Makefile ])
-AC_CONFIG_FILES([ tderadio3/plugins/timeshifter/po/Makefile ])
-AC_CONFIG_FILES([ tderadio3/plugins/v4lradio/Makefile ])
-AC_CONFIG_FILES([ tderadio3/plugins/v4lradio/po/Makefile ])
-AC_CONFIG_FILES([ tderadio3/presets/Makefile ])
-AC_CONFIG_FILES([ tderadio3/presets/argentina/Makefile ])
-AC_CONFIG_FILES([ tderadio3/presets/australia/Makefile ])
-AC_CONFIG_FILES([ tderadio3/presets/austria/Makefile ])
-AC_CONFIG_FILES([ tderadio3/presets/belgium/Makefile ])
-AC_CONFIG_FILES([ tderadio3/presets/brazil/Makefile ])
-AC_CONFIG_FILES([ tderadio3/presets/bulgaria/Makefile ])
-AC_CONFIG_FILES([ tderadio3/presets/canada/Makefile ])
-AC_CONFIG_FILES([ tderadio3/presets/catalonia/Makefile ])
-AC_CONFIG_FILES([ tderadio3/presets/czechia/Makefile ])
-AC_CONFIG_FILES([ tderadio3/presets/england/Makefile ])
-AC_CONFIG_FILES([ tderadio3/presets/england/buckinghamshire/Makefile ])
-AC_CONFIG_FILES([ tderadio3/presets/finland/Makefile ])
-AC_CONFIG_FILES([ tderadio3/presets/france/Makefile ])
-AC_CONFIG_FILES([ tderadio3/presets/germany/Makefile ])
-AC_CONFIG_FILES([ tderadio3/presets/hungary/Makefile ])
-AC_CONFIG_FILES([ tderadio3/presets/iceland/Makefile ])
-AC_CONFIG_FILES([ tderadio3/presets/ireland/Makefile ])
-AC_CONFIG_FILES([ tderadio3/presets/italy/Makefile ])
-AC_CONFIG_FILES([ tderadio3/presets/lithuania/Makefile ])
-AC_CONFIG_FILES([ tderadio3/presets/luxemburg/Makefile ])
-AC_CONFIG_FILES([ tderadio3/presets/netherlands/Makefile ])
-AC_CONFIG_FILES([ tderadio3/presets/new-zealand/Makefile ])
-AC_CONFIG_FILES([ tderadio3/presets/norway/Makefile ])
-AC_CONFIG_FILES([ tderadio3/presets/poland/Makefile ])
-AC_CONFIG_FILES([ tderadio3/presets/portugal/Makefile ])
-AC_CONFIG_FILES([ tderadio3/presets/romania/Makefile ])
-AC_CONFIG_FILES([ tderadio3/presets/russia/Makefile ])
-AC_CONFIG_FILES([ tderadio3/presets/slovakia/Makefile ])
-AC_CONFIG_FILES([ tderadio3/presets/south-africa/Makefile ])
-AC_CONFIG_FILES([ tderadio3/presets/spain/Makefile ])
-AC_CONFIG_FILES([ tderadio3/presets/sweden/Makefile ])
-AC_CONFIG_FILES([ tderadio3/presets/switzerland/Makefile ])
-AC_CONFIG_FILES([ tderadio3/presets/turkey/Makefile ])
-AC_CONFIG_FILES([ tderadio3/presets/uruguay/Makefile ])
-AC_CONFIG_FILES([ tderadio3/presets/usa/Makefile ])
-AC_CONFIG_FILES([ tderadio3/src/Makefile ])
-AC_CONFIG_FILES([ tderadio3/src/po/Makefile ])
+AC_CONFIG_FILES([ convert-presets/Makefile ])
+AC_CONFIG_FILES([ convert-presets/po/Makefile ])
+AC_CONFIG_FILES([ doc/Makefile ])
+AC_CONFIG_FILES([ doc/en/Makefile ])
+AC_CONFIG_FILES([ icons/Makefile ])
+AC_CONFIG_FILES([ plugins/Makefile ])
+AC_CONFIG_FILES([ plugins/alsa-sound/Makefile ])
+AC_CONFIG_FILES([ plugins/alsa-sound/icons/Makefile ])
+AC_CONFIG_FILES([ plugins/alsa-sound/po/Makefile ])
+AC_CONFIG_FILES([ plugins/gui-docking-menu/Makefile ])
+AC_CONFIG_FILES([ plugins/gui-docking-menu/po/Makefile ])
+AC_CONFIG_FILES([ plugins/gui-error-log/Makefile ])
+AC_CONFIG_FILES([ plugins/gui-error-log/po/Makefile ])
+AC_CONFIG_FILES([ plugins/gui-quickbar/Makefile ])
+AC_CONFIG_FILES([ plugins/gui-quickbar/po/Makefile ])
+AC_CONFIG_FILES([ plugins/gui-standard-display/Makefile ])
+AC_CONFIG_FILES([ plugins/gui-standard-display/po/Makefile ])
+AC_CONFIG_FILES([ plugins/lirc/Makefile ])
+AC_CONFIG_FILES([ plugins/lirc/po/Makefile ])
+AC_CONFIG_FILES([ plugins/oss-sound/Makefile ])
+AC_CONFIG_FILES([ plugins/oss-sound/icons/Makefile ])
+AC_CONFIG_FILES([ plugins/oss-sound/po/Makefile ])
+AC_CONFIG_FILES([ plugins/radio/Makefile ])
+AC_CONFIG_FILES([ plugins/radio/po/Makefile ])
+AC_CONFIG_FILES([ plugins/recording/Makefile ])
+AC_CONFIG_FILES([ plugins/recording/icons/Makefile ])
+AC_CONFIG_FILES([ plugins/recording/po/Makefile ])
+AC_CONFIG_FILES([ plugins/soundserver/Makefile ])
+AC_CONFIG_FILES([ plugins/soundserver/po/Makefile ])
+AC_CONFIG_FILES([ plugins/streaming/Makefile ])
+AC_CONFIG_FILES([ plugins/streaming/icons/Makefile ])
+AC_CONFIG_FILES([ plugins/streaming/po/Makefile ])
+AC_CONFIG_FILES([ plugins/timecontrol/Makefile ])
+AC_CONFIG_FILES([ plugins/timecontrol/icons/Makefile ])
+AC_CONFIG_FILES([ plugins/timecontrol/po/Makefile ])
+AC_CONFIG_FILES([ plugins/timeshifter/Makefile ])
+AC_CONFIG_FILES([ plugins/timeshifter/icons/Makefile ])
+AC_CONFIG_FILES([ plugins/timeshifter/po/Makefile ])
+AC_CONFIG_FILES([ plugins/v4lradio/Makefile ])
+AC_CONFIG_FILES([ plugins/v4lradio/po/Makefile ])
+AC_CONFIG_FILES([ presets/Makefile ])
+AC_CONFIG_FILES([ presets/argentina/Makefile ])
+AC_CONFIG_FILES([ presets/australia/Makefile ])
+AC_CONFIG_FILES([ presets/austria/Makefile ])
+AC_CONFIG_FILES([ presets/belarus/Makefile ])
+AC_CONFIG_FILES([ presets/belgium/Makefile ])
+AC_CONFIG_FILES([ presets/brazil/Makefile ])
+AC_CONFIG_FILES([ presets/bulgaria/Makefile ])
+AC_CONFIG_FILES([ presets/canada/Makefile ])
+AC_CONFIG_FILES([ presets/catalonia/Makefile ])
+AC_CONFIG_FILES([ presets/colombia/Makefile ])
+AC_CONFIG_FILES([ presets/croatia/Makefile ])
+AC_CONFIG_FILES([ presets/czechia/Makefile ])
+AC_CONFIG_FILES([ presets/england/Makefile ])
+AC_CONFIG_FILES([ presets/england/buckinghamshire/Makefile ])
+AC_CONFIG_FILES([ presets/finland/Makefile ])
+AC_CONFIG_FILES([ presets/france/Makefile ])
+AC_CONFIG_FILES([ presets/germany/Makefile ])
+AC_CONFIG_FILES([ presets/greece/Makefile ])
+AC_CONFIG_FILES([ presets/hungary/Makefile ])
+AC_CONFIG_FILES([ presets/iceland/Makefile ])
+AC_CONFIG_FILES([ presets/india/Makefile ])
+AC_CONFIG_FILES([ presets/ireland/Makefile ])
+AC_CONFIG_FILES([ presets/italy/Makefile ])
+AC_CONFIG_FILES([ presets/lithuania/Makefile ])
+AC_CONFIG_FILES([ presets/luxemburg/Makefile ])
+AC_CONFIG_FILES([ presets/netherlands/Makefile ])
+AC_CONFIG_FILES([ presets/new-zealand/Makefile ])
+AC_CONFIG_FILES([ presets/norway/Makefile ])
+AC_CONFIG_FILES([ presets/poland/Makefile ])
+AC_CONFIG_FILES([ presets/portugal/Makefile ])
+AC_CONFIG_FILES([ presets/romania/Makefile ])
+AC_CONFIG_FILES([ presets/russia/Makefile ])
+AC_CONFIG_FILES([ presets/slovakia/Makefile ])
+AC_CONFIG_FILES([ presets/south-africa/Makefile ])
+AC_CONFIG_FILES([ presets/spain/Makefile ])
+AC_CONFIG_FILES([ presets/sweden/Makefile ])
+AC_CONFIG_FILES([ presets/switzerland/Makefile ])
+AC_CONFIG_FILES([ presets/turkey/Makefile ])
+AC_CONFIG_FILES([ presets/ukraine/Makefile ])
+AC_CONFIG_FILES([ presets/uruguay/Makefile ])
+AC_CONFIG_FILES([ presets/usa/Makefile ])
+AC_CONFIG_FILES([ presets/vietnam/Makefile ])
+AC_CONFIG_FILES([ src/Makefile ])
+AC_CONFIG_FILES([ src/po/Makefile ])
AC_OUTPUT
# Check if KDE_SET_PREFIX was called, and --prefix was passed to configure
if test -n "$kde_libs_prefix" -a -n "$given_prefix"; then
@@ -405,17 +382,17 @@ if test -n "$kde_libs_prefix" -a -n "$given_prefix"; then
fi
fi
-if test x$GXX = "xyes" -a x$kde_have_gcc_visibility = "xyes" -a x$kde_cv_val_qt_gcc_visibility_patched = "xno"; then
+if test x$GXX = "xyes" -a x$kde_have_gcc_visibility = "xyes" -a x$kde_cv_val_tqt_gcc_visibility_patched = "xno"; then
echo ""
- echo "Your GCC supports symbol visibility, but the patch for Qt supporting visibility"
+ echo "Your GCC supports symbol visibility, but the patch for TQt supporting visibility"
echo "was not included. Therefore, GCC symbol visibility support remains disabled."
echo ""
- echo "For better performance, consider including the Qt visibility supporting patch"
+ echo "For better performance, consider including the TQt visibility supporting patch"
echo "located at:"
echo ""
echo "http://bugs.kde.org/show_bug.cgi?id=109386"
echo ""
- echo "and recompile all of Qt and KDE. Note, this is entirely optional and"
+ echo "and recompile all of TQt and KDE. Note, this is entirely optional and"
echo "everything will continue to work just fine without it."
echo ""
fi