summaryrefslogtreecommitdiffstats
path: root/plugins/soundserver/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/soundserver/Makefile.am')
-rw-r--r--plugins/soundserver/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/plugins/soundserver/Makefile.am b/plugins/soundserver/Makefile.am
new file mode 100644
index 0000000..bac5fe3
--- /dev/null
+++ b/plugins/soundserver/Makefile.am
@@ -0,0 +1,18 @@
+SUBDIRS = po .
+
+INCLUDES = $(all_includes)
+METASOURCES = AUTO
+
+libtderadio_LTLIBRARIES = libsoundserver.la
+
+libsoundserver_la_SOURCES = soundserver.cpp
+libsoundserver_la_LDFLAGS = -module -avoid-version $(KDE_RPATH) $(all_libraries)
+
+noinst_HEADERS = soundserver.h
+
+#messages: rc.cpp
+# $(XGETTEXT) *.cpp *.h -o po/tderadio-sound-server.pot
+
+messages: rc.cpp
+ $(EXTRACTRC) *.rc *.ui >> rc.cpp
+ $(XGETTEXT) rc.cpp *.h *.cpp -o po/tderadio-soundserver.pot