summaryrefslogtreecommitdiffstats
path: root/plugins/timecontrol/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/timecontrol/Makefile.am')
-rw-r--r--plugins/timecontrol/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/plugins/timecontrol/Makefile.am b/plugins/timecontrol/Makefile.am
new file mode 100644
index 0000000..edcda42
--- /dev/null
+++ b/plugins/timecontrol/Makefile.am
@@ -0,0 +1,17 @@
+SUBDIRS = po icons .
+
+INCLUDES = $(all_includes)
+METASOURCES = AUTO
+
+libtderadio_LTLIBRARIES = libtimecontrol.la
+libtimecontrol_la_SOURCES = timecontrol-configuration.cpp \
+ timecontrol-configuration-ui.ui timecontrol.cpp
+libtimecontrol_la_LDFLAGS = -module -avoid-version $(KDE_RPATH) $(all_libraries)
+noinst_HEADERS = timecontrol-configuration.h timecontrol.h
+
+#messages: rc.cpp
+# $(XGETTEXT) *.cpp *.h -o po/tderadio-timecontrol.pot
+
+messages: rc.cpp
+ $(EXTRACTRC) *.rc *.ui >> rc.cpp
+ $(XGETTEXT) rc.cpp *.h *.cpp -o po/tderadio-timecontrol.pot