summaryrefslogtreecommitdiffstats
path: root/ksim/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-05-22 02:49:40 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-05-24 15:49:49 +0200
commita1066b66a7b397f1cdac40d6970b9640184fe8f6 (patch)
tree023614a603e30a1f7a3ae99c3bbc366fcb4b2178 /ksim/CMakeLists.txt
parent2f27665e4d477b9016dc38bf4d83945a371f9c0d (diff)
downloadtdeutils-a1066b66a7b397f1cdac40d6970b9640184fe8f6.tar.gz
tdeutils-a1066b66a7b397f1cdac40d6970b9640184fe8f6.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 296306a273438f476ab2266d1c03616de1fd5ef7)
Diffstat (limited to 'ksim/CMakeLists.txt')
-rw-r--r--ksim/CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/ksim/CMakeLists.txt b/ksim/CMakeLists.txt
index 59037f7..20fc59e 100644
--- a/ksim/CMakeLists.txt
+++ b/ksim/CMakeLists.txt
@@ -50,12 +50,12 @@ tde_add_kpart( ksim_panelextension AUTOMOC
##### other data ################################
-install( FILES ksim.desktop
- DESTINATION
- ${DATA_INSTALL_DIR}/kicker/extensions
+tde_create_translated_desktop(
+ SOURCE ksim.desktop
+ DESTINATION ${DATA_INSTALL_DIR}/kicker/extensions
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/ksim-desktops
)
install( FILES ksim_panelextensionrc
DESTINATION ${CONFIG_INSTALL_DIR}
)
-