summaryrefslogtreecommitdiffstats
path: root/kcalc/knumber/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kcalc/knumber/tests/Makefile.am')
-rw-r--r--kcalc/knumber/tests/Makefile.am32
1 files changed, 32 insertions, 0 deletions
diff --git a/kcalc/knumber/tests/Makefile.am b/kcalc/knumber/tests/Makefile.am
new file mode 100644
index 0000000..73b0600
--- /dev/null
+++ b/kcalc/knumber/tests/Makefile.am
@@ -0,0 +1,32 @@
+# This file is part of the KDE libraries
+# Copyright (C) 1996-1997 Matthias Kalle Dalheimer (kalle@kde.org)
+# (C) 1997-1998 Stephan Kulow (coolo@kde.org)
+
+# This library is free software; you can redistribute it and/or
+# modify it under the terms of the GNU Library General Public
+# License as published by the Free Software Foundation; either
+# version 2 of the License, or (at your option) any later version.
+
+# This library is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# Library General Public License for more details.
+
+# You should have received a copy of the GNU Library General Public License
+# along with this library; see the file COPYING.LIB. If not, write to
+# the Free Software Foundation, Inc., 51 Franklin Street, Fifth Floor,
+# Boston, MA 02110-1301, USA.
+
+INCLUDES = -I$(top_srcdir)/kcalc/knumber $(all_includes)
+
+check_PROGRAMS = knumbertest
+
+TESTS = knumbertest
+
+noinst_HEADERS = knumbertest.h
+
+METASOURCES = AUTO
+
+knumbertest_SOURCES = knumbertest.cpp
+knumbertest_LDADD = ../libknumber.la $(LIB_QT) $(LIBGMP)
+knumbertest_LDFLAGS = $(all_libraries) $(KDE_RPATH)