summaryrefslogtreecommitdiffstats
path: root/khexedit/lib/codecs/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'khexedit/lib/codecs/Makefile.am')
-rw-r--r--khexedit/lib/codecs/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/khexedit/lib/codecs/Makefile.am b/khexedit/lib/codecs/Makefile.am
new file mode 100644
index 0000000..0c208b7
--- /dev/null
+++ b/khexedit/lib/codecs/Makefile.am
@@ -0,0 +1,15 @@
+INCLUDES = -I$(srcdir)/.. $(all_includes)
+
+METASOURCES = AUTO
+
+#
+noinst_LTLIBRARIES = libkhecodecs.la
+libkhecodecs_la_SOURCES = kcharcodec.cpp kbytecodec.cpp \
+ ktextcharcodec.cpp kebcdic1047charcodec.cpp \
+ kbinarybytecodec.cpp koctalbytecodec.cpp \
+ kdecimalbytecodec.cpp khexadecimalbytecodec.cpp
+
+# no public API
+noinst_HEADERS = ktextcharcodec.h kebcdic1047charcodec.h \
+ kbinarybytecodec.h koctalbytecodec.h \
+ kdecimalbytecodec.h khexadecimalbytecodec.h \ No newline at end of file